Listing Input Forms in TransactionDesk Update

Incident Report for NNRMLS

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 10:33 PDT

Identified

The following forms are now available in TransactionDesk:
-Residential Listing Input Form
-Business Opportunity Listing Input Form
-Status Change Form

We’re actively working on improvements to the Residential Input Form. Here’s what's being addressed:
-Missing Listing Term VA Loan: The listing term Veterans Affairs Loan is currently absent and will be added.
-Water Body Features Cleanup: Some options are missing, while others are duplicated. We’re fixing both.
-General Typos: Minor wording and formatting issues are being corrected for clarity and consistency.

The remaining forms will follow shortly. Subscribe to the NNRMLS Status Page for current updates.
Posted Jun 10, 2025 - 11:38 PDT
This incident affected: TransactionDesk.