Slow Load/Load Timeout for Flexmls/Member Launchpad

Incident Report for NNRMLS

Identified

The issue appears to stem from a bad connection from Spectrum between Northern Nevada and FBS's Datacenter.
Posted Dec 19, 2025 - 08:10 PST

Investigating

Some users are experiencing slow load times/load timeouts for the Member Launchpad, Flexmls, and SSO services from the Member Launchpad. NNRMLS has confirmed the issue. While the issue is not related to FBS/Flex directly, both NNRMLS and FBS are investigating the issue in order to resolve.

Updates will be posted here as they become available.
Posted Dec 18, 2025 - 11:14 PST
This incident affects: Flexmls (Flexmls).