Phishing Warning

Incident Report for NNRMLS

Resolved

This issue has been resolved.
Posted Jul 01, 2025 - 10:33 PDT

Investigating

We have received reports of phishing attempts via the Find a Realtor integration page on NNRMLS.com. We are currently investigating this issue. If you have received a contact request email from the NNRMLS Consumer Portal please exercise caution and feel free to reach out to us with any questions or concerns.
Updates will be posted to the System Status Page at status.nnrmls.com.
Posted May 07, 2025 - 11:06 PDT
This incident affected: NNRMLS Website.