Intermittent Connection Issues With NNRMLS Phone System.

Incident Report for NNRMLS

Resolved

There was a temporary outage involving our internet service provider. This disruption has been resolved, and after monitoring throughout the day, we can confirm that all phone services have been fully restored.
Posted Jul 15, 2025 - 15:51 PDT

Investigating

Our office phone system is currently impacted by an issue with our Internet Service Provider. The intermittent issue is disrupting inbound and outbound phone calls.
Posted Jul 14, 2025 - 15:39 PDT
This incident affected: Phone Systems.